ospf and rip redistribution

ospf redistribution

ospf redistribution is when you take a route from one routing protocol and inject it or distribute it into another protocol. By default, routers only advertise and share routes with other routers running the same protocol. So if you have 2 routers and one runs OSPF and the other runs RIP and you want them to know about each others routes, by default, they won’t share routing information because they are not running the same protocol.

Network Topology

 

Configuration on router 1

Router>en

Router#conf t

Enter configuration commands, one per line. End with CNTL/Z.

Router(config)#int se 0/0/0

Router(config-if)#ip address 10.0.0.2 255.0.0.0

Router(config-if)#no sh

%LINK-5-CHANGED: Interface Serial0/0/0, changed state to down

Router(config-if)#int se 0/0/1

Router(config-if)#ip address 20.0.0.1 255.0.0.0

Router(config-if)#no sh

Router(config)#router rip

Router(config-router)#ver 2

Router(config-router)#net 10.0.0.0

Router(config-router)#exit

Router(config)#router ospf 10

Router(config-router)#net 20.0.0.0 0.255.255.255 area 10

 

On router 2

Router>

Router>en

Router#conf t

Enter configuration commands, one per line. End with CNTL/Z.

Router(config)#int se 0/0/0

Router(config-if)#ip address 10.0.0.1 255.0.0.0

Router(config-if)#no sh

%LINK-5-CHANGED: Interface Serial0/0/0, changed state to up

Router(config-if)#router rip

Router(config-router)#ver 2

Router(config-router)#net 10.0.0.0

%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0/0, changed state to up

 

On router 3

Router>en

Router#conf t

Enter configuration commands, one per line. End with CNTL/Z.

Router(config)#int se 0/0/0

Router(config-if)#ip add 20.0.0.2 255.0.0.0

Router(config-if)#no sh

%LINK-5-CHANGED: Interface Serial0/0/0, changed state to up

Router(config-if)#router ospf 10

%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0/0, changed state to up

Router(config-router)#net 20.0.0.0 0.255.255.255 area 10

00:06:54: %OSPF-5-ADJCHG: Process 10, Nbr 20.0.0.1 on Serial0/0/0 from LOADING to FULL, Loading Done

 

Redistribution Commands on center Router

 

Router(config)#router rip

Router(config-router)#redistribute ospf 10 metric 1

Router(config-router)#exit

Router(config)#

 

Router(config)#router ospf 10

Router(config-router)#redistribute rip subnets

see the result message is passing across the different protocol

In a router, route redistribution allows a network that uses one routing protocol to route traffic dynamically based on information learned from another routing protocol.In a small network such as a home or home office, a default route is often used to send all traffic to the user’s Internet service provider. Likewise, medium-sized networks such as branch offices or small Internet service providers may use default routes for traffic intended for the public Internet. But in medium-sized and large networks, routers use dynamic routing protocols to determine the best paths to various network destinations.

 

110 thoughts on “ospf and rip redistribution

Leave a Reply

Your email address will not be published. Required fields are marked *

  1. I’m impressed, I have to admit. Actually rarely can i encounter a blog that’s both educative and entertaining, and without a doubt, you’ve got hit the nail to the head. Your concept is outstanding; ab muscles an issue that not enough people are speaking intelligently about. I will be delighted that we stumbled across this within my seek out something about it.

  2. Thanks a lot for providing individuals with an extremely pleasant chance to read critical reviews from this web site. It’s usually so pleasurable and full of fun for me and my office acquaintances to visit your blog really 3 times a week to read through the new secrets you will have. Of course, I’m just at all times fascinated for the attractive information served by you. Certain 3 areas in this article are definitely the most efficient we have ever had.

  3. I have not checked in here for some time since I thought it was getting boring, but the last few posts are good quality so I guess I will add you back to my daily bloglist. You deserve it my friend 🙂

  4. wonderful post, very informative. I wonder why the other experts of this sector don’t notice this. You should proceed your writing. I’m confident, you’ve a great readers’ base already!

  5. you are really a excellent webmaster. The web site loading velocity is amazing. It seems that you are doing any unique trick. Also, The contents are masterwork. you’ve performed a fantastic activity on this topic!

  6. There are extremely plenty of details prefer that to consider. That is a great denote talk about. I provide thoughts above as general inspiration but clearly you can find questions just like the one you start up the place that the most important factor will be getting work done in honest excellent faith. I don?t determine if recommendations have emerged around such things as that, but Almost certainly that your chosen job is clearly identified as a good game. Both youngsters notice the impact of simply a moment’s pleasure, throughout their lives.

  7. I simply want to say I am just beginner to blogs and definitely savored you’re website. Most likely I’m planning to bookmark your site . You amazingly come with outstanding well written articles. Appreciate it for revealing your web page.

  8. It is perfect time to make a few plans for the future and it’s time to be happy. I have learn this submit and if I may I want to suggest you some attention-grabbing things or suggestions. Perhaps you can write subsequent articles relating to this article. I want to learn more things about it!

  9. “Do you have a spam problem on this site; I also am a blogger, and I was wanting to know your situation; many of us have created some nice practices and we are looking to trade methods with other folks, please shoot me an e-mail if interested.”

Please wait...

Subscribe to our newsletter

Want to be notified when our article is published? Enter your email address and name below to be the first to know.