EIGRP

EIGRP

EIGRP stands for Enhanced Interior Gateway Routing Protocol  is an interior gateway protocol .

This protocol was earlier IGRP (interior gateway routing protocol) but was later was modified by cisco and now this protocol only works on the cisco routers.

It uses the Diffusing-Update Algorithm (DUAL) to determine the most efficient (least cost) route to a destination.

This protocol supports VLSM , class less routing and route summarization.

This is a advanced distant vector routing protocol.

The protocol contains

•    Neighbor table – stores information about neighbors
•    Topology table – stores routing information learned from neighboring routers
•    Routing table –  stores the best routes

this protocol uses the concept to autonomous system number.

the routers running on same autonomous system number communicate with each other .

 
LAB configuration of the protocol
EIGRP
in the above lab we are using two cisco 2811 series router and two 24 ports switch and pc’s

Router(config)#int fa 0/0

Router(config-if)#ip add 10.0.0.1 255.0.0.0

Router(config-if)#no sh

Router(config-if)#

%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up

Router(config-if)#exit

Router(config)#int se 0/1/0

Router(config-if)#ip add 20.0.0.1 255.0.0.0

Router(config-if)#no sh

Router(config)#router eigrp ?

<1-65535> Autonomous system number

Router(config)#router eigrp 10

Router(config-router)#network 10.0.0.0 0.255.255.255

Router(config-router)#network 20.0.0.0 0.255.255.255

Router(config-router)#exit

applying DHCP

Router(config)#ip dhcp pool sachtech

Router(dhcp-config)#network 10.0.0.0 255.0.0.0

Router(dhcp-config)#default-router 10.0.0.1

Router(dhcp-config)#dns-server 8.8.8.8

now we will configure router 2

EIGRP

Router(config-if)#int fa 0/0

Router(config-if)#ip add 30.0.0.1 255.0.0.0

Router(config-if)#no sh

Router(config-if)#exit

Router(config)#int se 0/0/0

Router(config-if)#ip add 20.0.0.2 255.0.0.0

Router(config-if)#no sh

now lets configure eigrp protocol

EIGRP

Router(config)#router eigrp 10

Router(config-router)#network 20.0.0.0 0.255.255.255

Router(config-router)#network 30.0.0.0 0.255.255.255

now most importantly lets check the connectivity between the different pc

EIGRP

as we see below all the pc are able to ping each other successfully .

 

 

EIGRP

Router#sh ip route

C 10.0.0.0/8 is directly connected, FastEthernet0/0

C 20.0.0.0/8 is directly connected, Serial0/1/0

D 30.0.0.0/8 [90/2172416] via 20.0.0.2, 00:05:43, Serial0/1/0

and its done

 

 

 

46 thoughts on “EIGRP

Leave a Reply

Your email address will not be published. Required fields are marked *

  1. I feel that is one of the most important information for me. And i’m happy studying your article. However should observation on few general issues, The site style is great, the articles is really great : D. Excellent activity, cheers

  2. I just want to mention I’m new to blogging and certainly loved this website. Almost certainly I’m going to bookmark your site . You absolutely have perfect writings. Appreciate it for sharing your web page.

  3. I am often to blogging i actually appreciate your site content. The content has really peaks my interest. I am going to bookmark your web blog and maintain checking for brand new information.

  4. In this awesome scheme of things you actually get an A+ just for hard work. Exactly where you lost everybody ended up being in your particulars. You know, people say, details make or break the argument.. And that could not be much more true here. Having said that, permit me say to you what exactly did give good results. The article (parts of it) is actually incredibly powerful which is most likely the reason why I am making the effort in order to comment. I do not really make it a regular habit of doing that. Secondly, although I can certainly see the jumps in reason you come up with, I am not really sure of exactly how you seem to connect your ideas which inturn make the actual conclusion. For the moment I will yield to your point however wish in the foreseeable future you connect your dots much better.

  5. of course like your website however you have to take a look at the spelling on several of your posts. Many of them are rife with spelling issues and I to find it very bothersome to tell the reality on the other hand I’ll surely come back again.

  6. What’s Taking place i am new to this, I stumbled upon this I’ve discovered It absolutely useful and it has helped me out loads. I’m hoping to contribute & assist other users like its helped me. Great job.

  7. I do love the way you have framed this concern and it does offer us some fodder for consideration. However, from what precisely I have witnessed, I basically wish when other feedback pile on that men and women stay on issue and in no way embark upon a soap box associated with some other news of the day. Still, thank you for this outstanding piece and though I can not really go along with it in totality, I regard the perspective.

  8. I’ve been exploring for a little bit for any high quality articles or weblog posts on this kind of space . Exploring in Yahoo I ultimately stumbled upon this site. Reading this information So i am happy to exhibit that I’ve an incredibly good uncanny feeling I came upon exactly what I needed. I most unquestionably will make certain to do not forget this site and provides it a look regularly.

  9. Heya i’m for the primary time here. I found this board and I in finding It truly helpful & it helped me out a lot. I’m hoping to present one thing back and help others such as you aided me.

  10. Excellent blog you have here but I was curious about if you knew of any message boards that cover the same topics talked about in this article? I’d really like to be a part of online community where I can get opinions from other experienced people that share the same interest. If you have any suggestions, please let me know. Appreciate it!

  11. I’m really enjoying the design and layout of your site.
    It’s a very easy on the eyes which makes it much more pleasant
    for me to come here and visit more often. Did you hire out a
    designer to create your theme? Great work!

  12. Having read this I believed it was really informative. I appreciate you spending some time and energy to put this information together.

    I once again find myself spending a lot of time both reading and posting comments.
    But so what, it was still worth it!

Please wait...

Subscribe to our newsletter

Want to be notified when our article is published? Enter your email address and name below to be the first to know.